Openoffice Apache Openoffice

Do you want an email whenever new security vulnerabilities are reported in Apache Openoffice?

By the Year

In 2022 there have been 0 vulnerabilities in Apache Openoffice . Last year Openoffice had 7 security vulnerabilities published. Right now, Openoffice is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 7 7.31
2020 1 7.80
2019 0 0.00
2018 1 7.50

It may take a day or so for new Openoffice vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Apache Openoffice Security Vulnerabilities

It is possible for an attacker to manipulate documents to appear to be signed by a trusted source

CVE-2021-41832 7.5 - High - October 11, 2021

It is possible for an attacker to manipulate documents to appear to be signed by a trusted source. All versions of Apache OpenOffice up to 4.1.10 are affected. Users are advised to update to version 4.1.11. See CVE-2021-25635 for the LibreOffice advisory.

Improper Verification of Cryptographic Signature

It is possible for an attacker to manipulate the timestamp of signed documents

CVE-2021-41831 5.3 - Medium - October 11, 2021

It is possible for an attacker to manipulate the timestamp of signed documents. All versions of Apache OpenOffice up to 4.1.10 are affected. Users are advised to update to version 4.1.11. See CVE-2021-25634 for the LibreOffice advisory.

Improper Verification of Cryptographic Signature

It is possible for an attacker to manipulate signed documents and macros to appear to come from a trusted source

CVE-2021-41830 7.5 - High - October 11, 2021

It is possible for an attacker to manipulate signed documents and macros to appear to come from a trusted source. All versions of Apache OpenOffice up to 4.1.10 are affected. Users are advised to update to version 4.1.11. See CVE-2021-25633 for the LibreOffice advisory.

Improper Verification of Cryptographic Signature

While working on Apache OpenOffice 4.1.8 a developer discovered

CVE-2021-28129 7.8 - High - October 07, 2021

While working on Apache OpenOffice 4.1.8 a developer discovered that the DEB package did not install using root, but instead used a userid and groupid of 500. This both caused issues with desktop integration and could allow a crafted attack on files owned by that user or group if they exist. Users who installed the Apache OpenOffice 4.1.8 DEB packaging should upgrade to the latest version of Apache OpenOffice.

Improper Privilege Management

Apache OpenOffice has a dependency on expat software

CVE-2021-40439 6.5 - Medium - October 07, 2021

Apache OpenOffice has a dependency on expat software. Versions prior to 2.1.0 were subject to CVE-2013-0340 a "Billion Laughs" entity expansion denial of service attack and exploit via crafted XML files. ODF files consist of a set of XML files. All versions of Apache OpenOffice up to 4.1.10 are subject to this issue. expat in version 4.1.11 is patched.

XXE

Apache OpenOffice opens dBase/DBF documents and shows the contents as spreadsheets

CVE-2021-33035 7.8 - High - September 23, 2021

Apache OpenOffice opens dBase/DBF documents and shows the contents as spreadsheets. DBF are database files with data organized in fields. When reading DBF data the size of certain fields is not checked: the data is just copied into local variables. A carefully crafted document could overflow the allocated space, leading to the execution of arbitrary code by altering the contents of the program stack. This issue affects Apache OpenOffice up to and including version 4.1.10

Classic Buffer Overflow

The project received a report that all versions of Apache OpenOffice through 4.1.8 can open non-http(s) hyperlinks

CVE-2021-30245 8.8 - High - April 15, 2021

The project received a report that all versions of Apache OpenOffice through 4.1.8 can open non-http(s) hyperlinks. The problem has existed since about 2006 and the issue is also in 4.1.9. If the link is specifically crafted this could lead to untrusted code execution. It is always best practice to be careful opening documents from unknown and unverified sources. The mitigation in Apache OpenOffice 4.1.10 (unreleased) assures that a security warning is displayed giving the user the option of continuing to open the hyperlink.

Externally Controlled Reference to a Resource in Another Sphere

A vulnerability in Apache OpenOffice scripting events

CVE-2020-13958 7.8 - High - November 17, 2020

A vulnerability in Apache OpenOffice scripting events allows an attacker to construct documents containing hyperlinks pointing to an executable on the target users file system. These hyperlinks can be triggered unconditionally. In fixed versions no internal protocol may be called from the document event handler and other hyperlinks require a control-click.

An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache OpenOffice Writer 4.1.5 automatically process and initiate an SMB connection embedded in a malicious file

CVE-2018-10583 7.5 - High - May 01, 2018

An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache OpenOffice Writer 4.1.5 automatically process and initiate an SMB connection embedded in a malicious file, as demonstrated by xlink:href=file://192.168.0.2/test.jpg within an office:document-content element in a .odt XML document.

Information Disclosure

Double free vulnerability in libxml2 2.7.8 and other versions, as used in Google Chrome before 8.0.552.215 and other products

CVE-2010-4494 - December 07, 2010

Double free vulnerability in libxml2 2.7.8 and other versions, as used in Google Chrome before 8.0.552.215 and other products, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to XPath handling.

Double-free

libxml2 before 2.7.8, as used in Google Chrome before 7.0.517.44, Apple Safari 5.0.2 and earlier, and other products, reads from invalid memory locations during processing of malformed XPath expressions, which

CVE-2010-4008 - November 17, 2010

libxml2 before 2.7.8, as used in Google Chrome before 7.0.517.44, Apple Safari 5.0.2 and earlier, and other products, reads from invalid memory locations during processing of malformed XPath expressions, which allows context-dependent attackers to cause a denial of service (application crash) via a crafted XML document.

Buffer Overflow

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Suse Linux Enterprise Server or by Apache? Click the Watch button to subscribe.

Apache
Vendor

subscribe