Dogtagpki Dogtagpki

Do you want an email whenever new security vulnerabilities are reported in Dogtagpki?

By the Year

In 2022 there have been 2 vulnerabilities in Dogtagpki with an average score of 7.7 out of ten. Last year Dogtagpki had 3 security vulnerabilities published. At the current rates, it appears that the number of vulnerabilities last year and this year may equal out. However, the average CVE base score of the vulnerabilities in 2022 is greater by 0.88.

Year Vulnerabilities Average Score
2022 2 7.65
2021 3 6.77
2020 7 5.71
2019 0 0.00
2018 1 8.10

It may take a day or so for new Dogtagpki vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Dogtagpki Security Vulnerabilities

Access to external entities when parsing XML documents can lead to XML external entity (XXE) attacks

CVE-2022-2414 7.5 - High - July 29, 2022

Access to external entities when parsing XML documents can lead to XML external entity (XXE) attacks. This flaw allows a remote attacker to potentially retrieve the content of arbitrary files by sending specially crafted HTTP requests.

XXE

A flaw was found in the PKI-server

CVE-2021-3551 7.8 - High - February 16, 2022

A flaw was found in the PKI-server, where the spkispawn command, when run in debug mode, stores admin credentials in the installation log file. This flaw allows a local attacker to retrieve the file to obtain the admin password and gain admin privileges to the Dogtag CA manager. The highest threat from this vulnerability is to confidentiality.

Cleartext Storage of Sensitive Information

A flaw was found in pki-core 10.9.0

CVE-2020-25715 6.1 - Medium - May 28, 2021

A flaw was found in pki-core 10.9.0. A specially crafted POST request can be used to reflect a DOM-based cross-site scripting (XSS) attack to inject code into the search query form which can get automatically executed. The highest threat from this vulnerability is to data integrity.

XSS

A flaw was found in the Key Recovery Authority (KRA) Agent Service in pki-core 10.10.5 where it did not properly sanitize the recovery ID during a key recovery request

CVE-2020-1721 6.1 - Medium - April 30, 2021

A flaw was found in the Key Recovery Authority (KRA) Agent Service in pki-core 10.10.5 where it did not properly sanitize the recovery ID during a key recovery request, enabling a reflected cross-site scripting (XSS) vulnerability. An attacker could trick an authenticated victim into executing specially crafted Javascript code.

XSS

A flaw was found in pki-core

CVE-2021-20179 8.1 - High - March 15, 2021

A flaw was found in pki-core. An attacker who has successfully compromised a key could use this flaw to renew the corresponding certificate over and over again, as long as it is not explicitly revoked. The highest threat from this vulnerability is to data confidentiality and integrity.

AuthZ

In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation

CVE-2020-15720 6.8 - Medium - July 14, 2020

In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.

Improper Certificate Validation

A vulnerability was found in all pki-core 10.x.x version

CVE-2019-10180 4.8 - Medium - March 31, 2020

A vulnerability was found in all pki-core 10.x.x version, where the Token Processing Service (TPS) did not properly sanitize several parameters stored for the tokens, possibly resulting in a Stored Cross Site Scripting (XSS) vulnerability. An attacker able to modify the parameters of any token could use this flaw to trick an authenticated user into executing arbitrary JavaScript code.

XSS

A flaw was found in the all pki-core 10.x.x versions

CVE-2020-1696 5.4 - Medium - March 20, 2020

A flaw was found in the all pki-core 10.x.x versions, where Token Processing Service (TPS) where it did not properly sanitize Profile IDs, enabling a Stored Cross-Site Scripting (XSS) vulnerability when the profile ID is printed. An attacker with sufficient permissions could trick an authenticated victim into executing a specially crafted Javascript code.

XSS

A vulnerability was found in all pki-core 10.x.x versions

CVE-2019-10179 6.1 - Medium - March 20, 2020

A vulnerability was found in all pki-core 10.x.x versions, where the Key Recovery Authority (KRA) Agent Service did not properly sanitize recovery request search page, enabling a Reflected Cross Site Scripting (XSS) vulnerability. An attacker could trick an authenticated victim into executing specially crafted Javascript code.

XSS

A Reflected Cross Site Scripting vulnerability was found in all pki-core 10.x.x versions, where the pki-ca module from the pki-core server

CVE-2019-10221 6.1 - Medium - March 20, 2020

A Reflected Cross Site Scripting vulnerability was found in all pki-core 10.x.x versions, where the pki-ca module from the pki-core server. This flaw is caused by missing sanitization of the GET URL parameters. An attacker could abuse this flaw to trick an authenticated user into clicking a specially crafted link which can execute arbitrary code when viewed in a browser.

XSS

It was found that the Token Processing Service (TPS) did not properly sanitize the Token IDs

CVE-2019-10178 6.1 - Medium - March 18, 2020

It was found that the Token Processing Service (TPS) did not properly sanitize the Token IDs from the "Activity" page, enabling a Stored Cross Site Scripting (XSS) vulnerability. An unauthenticated attacker could trick an authenticated victim into creating a specially crafted activity, which would execute arbitrary JavaScript code when viewed in a browser. All versions of pki-core are believed to be vulnerable.

XSS

A Reflected Cross Site Scripting flaw was found in all pki-core 10.x.x versions module

CVE-2019-10146 4.7 - Medium - March 18, 2020

A Reflected Cross Site Scripting flaw was found in all pki-core 10.x.x versions module from the pki-core server due to the CA Agent Service not properly sanitizing the certificate request page. An attacker could inject a specially crafted value that will be executed on the victim's browser.

XSS

Dogtag PKI, through version 10.6.1, has a vulnerability in AAclAuthz.java

CVE-2018-1080 8.1 - High - July 03, 2018

Dogtag PKI, through version 10.6.1, has a vulnerability in AAclAuthz.java that, under certain configurations, causes the application of ACL allow and deny rules to be reversed. If a server is configured to process allow rules before deny rules (authz.evaluateOrder=allow,deny), then allow rules will deny access and deny rules will grant access. This may result in an escalation of privileges or have other unintended consequences.

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Dogtagpki or by Dogtagpki? Click the Watch button to subscribe.

Dogtagpki
Vendor

Dogtagpki
Product

subscribe