Pip Pypa Pip

Do you want an email whenever new security vulnerabilities are reported in Pypa Pip?

By the Year

In 2022 there have been 0 vulnerabilities in Pypa Pip . Last year Pip had 1 security vulnerability published. Right now, Pip is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 1 5.70
2020 2 7.65
2019 0 0.00
2018 0 0.00

It may take a day or so for new Pip vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Pypa Pip Security Vulnerabilities

A flaw was found in python-pip in the way it handled Unicode separators in git references

CVE-2021-3572 5.7 - Medium - November 10, 2021

A flaw was found in python-pip in the way it handled Unicode separators in git references. A remote attacker could possibly use this issue to install a different revision on a repository. The highest threat from this vulnerability is to data integrity. This is fixed in python-pip version 21.1.

The pip package before 19.2 for Python

CVE-2019-20916 7.5 - High - September 04, 2020

The pip package before 19.2 for Python allows Directory Traversal when a URL is given in an install command, because a Content-Disposition header can have ../ in a filename, as demonstrated by overwriting the /root/.ssh/authorized_keys file. This occurs in _download_http_url in _internal/download.py.

Directory traversal

** DISPUTED ** An issue was discovered in pip (all versions)

CVE-2018-20225 7.8 - High - May 08, 2020

** DISPUTED ** An issue was discovered in pip (all versions) because it installs the version with the highest version number, even if the user had intended to obtain a private package from a private index. This only affects use of the --extra-index-url option, and exploitation requires that the package does not already exist in the public index (and thus the attacker can put the package there with an arbitrary version number). NOTE: it has been reported that this is intended functionality and the user is responsible for using --extra-index-url securely.

Improper Input Validation

pip 1.3 through 1.5.6

CVE-2014-8991 - November 24, 2014

pip 1.3 through 1.5.6 allows local users to cause a denial of service (prevention of package installation) by creating a /tmp/pip-build-* file for another user.

pip before 1.3 allows local users to overwrite arbitrary files

CVE-2013-1888 - August 17, 2013

pip before 1.3 allows local users to overwrite arbitrary files via a symlink attack on a file in the /tmp/pip-build temporary directory.

insecure temporary file

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which

CVE-2013-1629 - August 06, 2013

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Improper Input Validation

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Pypa Pip or by Pypa? Click the Watch button to subscribe.

Pypa
Vendor

Pypa Pip
Product

subscribe