Phpmyadmin phpMyAdmin

stack.watch can notify you when security vulnerabilities are reported in phpMyAdmin. You can add multiple products that you use with Phpmyadmin to create your own personal software stack watcher.

By the Year

In 2020 there have been 5 vulnerabilities in phpMyAdmin with an average score of 7.2 out of ten. Last year Phpmyadmin had 7 security vulnerabilities published. If vulnerabilities keep coming in at the current rate, it appears that number of security vulnerabilities in Phpmyadmin in 2020 could surpass last years number. Last year, the average CVE base score was greater by 1.04

Year Vulnerabilities Average Score
2020 5 7.26
2019 7 8.30
2018 8 7.08

It may take a day or so for new Phpmyadmin vulnerabilities to show up. Additionally vulnerabilities may be tagged under a different product or component name.

Latest phpMyAdmin Security Vulnerabilities

** DISPUTED ** phpMyAdmin 5.0.2

CVE-2020-11441 6.1 - Medium - March 31, 2020

** DISPUTED ** phpMyAdmin 5.0.2 allows CRLF injection, as demonstrated by %0D%0Astring%0D%0A inputs to login form fields causing CRLF sequences to be reflected on an error page. NOTE: the vendor states "I don't see anything specifically exploitable."

Downstream Injection

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2

CVE-2020-10802 8 - High - March 22, 2020

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2

CVE-2020-10803 5.4 - Medium - March 22, 2020

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2

CVE-2020-10804 8 - High - March 22, 2020

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page

CVE-2020-5504 8.8 - High - January 09, 2020

In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

phpMyAdmin before 4.9.2 does not escape certain Git information

CVE-2019-19617 9.8 - Critical - December 06, 2019

phpMyAdmin before 4.9.2 does not escape certain Git information, related to libraries/classes/Display/GitRevision.php and libraries/classes/Footer.php.

An issue was discovered in phpMyAdmin before 4.9.2

CVE-2019-18622 9.8 - Critical - November 22, 2019

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

A CSRF issue in phpMyAdmin 4.9.0.1

CVE-2019-12922 6.5 - Medium - September 13, 2019

A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.

352

An issue was discovered in phpMyAdmin before 4.9.0.1

CVE-2019-11768 9.8 - Critical - June 05, 2019

An issue was discovered in phpMyAdmin before 4.9.0.1. A vulnerability was reported where a specially crafted database name can be used to trigger an SQL injection attack through the designer feature.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

An issue was discovered in phpMyAdmin before 4.9.0

CVE-2019-12616 6.5 - Medium - June 05, 2019

An issue was discovered in phpMyAdmin before 4.9.0. A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim.

352

An issue was discovered in phpMyAdmin before 4.8.5

CVE-2019-6798 9.8 - Critical - January 26, 2019

An issue was discovered in phpMyAdmin before 4.8.5. A vulnerability was reported where a specially crafted username can be used to trigger a SQL injection attack through the designer feature.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

An issue was discovered in phpMyAdmin before 4.8.5

CVE-2019-6799 5.9 - Medium - January 26, 2019

An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of "options(MYSQLI_OPT_LOCAL_INFILE" calls.

Information Leak

An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature

CVE-2018-19968 6.5 - Medium - December 11, 2018

An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.

Information Leak

phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws

CVE-2018-19969 8.8 - High - December 11, 2018

phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

352

In phpMyAdmin before 4.8.4, an XSS vulnerability was found in the navigation tree, where an attacker

CVE-2018-19970 6.1 - Medium - December 11, 2018

In phpMyAdmin before 4.8.4, an XSS vulnerability was found in the navigation tree, where an attacker can deliver a payload to a user through a crafted database/table name.

XSS

An issue was discovered in phpMyAdmin before 4.8.3

CVE-2018-15605 6.1 - Medium - August 24, 2018

An issue was discovered in phpMyAdmin before 4.8.3. A Cross-Site Scripting vulnerability has been found where an attacker can use a crafted file to manipulate an authenticated user who loads that file through the import feature.

XSS

An issue was discovered in js/designer/move.js in phpMyAdmin before 4.8.2

CVE-2018-12581 6.1 - Medium - June 21, 2018

An issue was discovered in js/designer/move.js in phpMyAdmin before 4.8.2. A Cross-Site Scripting vulnerability has been found where an attacker can use a crafted database name to trigger an XSS attack when that database is referenced from the Designer feature.

XSS

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in

CVE-2018-12613 8.8 - High - June 21, 2018

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).

authentification

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF

CVE-2018-10188 8.8 - High - April 19, 2018

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

352

Cross-site scripting (XSS) vulnerability in db_central_columns.php in phpMyAdmin before 4.7.8

CVE-2018-7260 5.4 - Medium - February 21, 2018

Cross-site scripting (XSS) vulnerability in db_central_columns.php in phpMyAdmin before 4.7.8 allows remote authenticated users to inject arbitrary web script or HTML via a crafted URL.

XSS