Opensc Openscproject Opensc

Do you want an email whenever new security vulnerabilities are reported in Openscproject Opensc?

By the Year

In 2022 there have been 5 vulnerabilities in Openscproject Opensc with an average score of 5.3 out of ten. Opensc did not have any published security vulnerabilities last year. That is, 5 more vulnerabilities have already been reported in 2022 as compared to last year.

Year Vulnerabilities Average Score
2022 5 5.30
2021 0 0.00
2020 4 5.83
2019 6 6.32
2018 13 6.29

It may take a day or so for new Opensc vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Openscproject Opensc Security Vulnerabilities

Heap buffer overflow issues were found in Opensc before version 0.22.0 in pkcs15-oberthur.c

CVE-2021-42781 5.3 - Medium - April 18, 2022

Heap buffer overflow issues were found in Opensc before version 0.22.0 in pkcs15-oberthur.c that could potentially crash programs using the library.

Memory Corruption

Stack buffer overflow issues were found in Opensc before version 0.22.0 in various places

CVE-2021-42782 5.3 - Medium - April 18, 2022

Stack buffer overflow issues were found in Opensc before version 0.22.0 in various places that could potentially crash programs using the library.

Memory Corruption

A heap double free issue was found in Opensc before version 0.22.0 in sc_pkcs15_free_tokeninfo.

CVE-2021-42778 5.3 - Medium - April 18, 2022

A heap double free issue was found in Opensc before version 0.22.0 in sc_pkcs15_free_tokeninfo.

Operation on a Resource after Expiration or Release

A heap use after free issue was found in Opensc before version 0.22.0 in sc_file_valid.

CVE-2021-42779 5.3 - Medium - April 18, 2022

A heap use after free issue was found in Opensc before version 0.22.0 in sc_file_valid.

Dangling pointer

A use after return issue was found in Opensc before version 0.22.0 in insert_pin function

CVE-2021-42780 5.3 - Medium - April 18, 2022

A use after return issue was found in Opensc before version 0.22.0 in insert_pin function that could potentially crash programs using the library.

Unchecked Return Value

The TCOS smart card software driver in OpenSC before 0.21.0-rc1 has a stack-based buffer overflow in tcos_decipher.

CVE-2020-26572 5.5 - Medium - October 06, 2020

The TCOS smart card software driver in OpenSC before 0.21.0-rc1 has a stack-based buffer overflow in tcos_decipher.

Memory Corruption

The gemsafe GPK smart card software driver in OpenSC before 0.21.0-rc1 has a stack-based buffer overflow in sc_pkcs15emu_gemsafeGPK_init.

CVE-2020-26571 5.5 - Medium - October 06, 2020

The gemsafe GPK smart card software driver in OpenSC before 0.21.0-rc1 has a stack-based buffer overflow in sc_pkcs15emu_gemsafeGPK_init.

Memory Corruption

The Oberthur smart card software driver in OpenSC before 0.21.0-rc1 has a heap-based buffer overflow in sc_oberthur_read_file.

CVE-2020-26570 5.5 - Medium - October 06, 2020

The Oberthur smart card software driver in OpenSC before 0.21.0-rc1 has a heap-based buffer overflow in sc_oberthur_read_file.

Memory Corruption

OpenSC before 0.20.0 has a double free in coolkey_free_private_data

CVE-2019-20792 6.8 - Medium - April 29, 2020

OpenSC before 0.20.0 has a double free in coolkey_free_private_data because coolkey_add_object in libopensc/card-coolkey.c lacks a uniqueness check.

Double-free

An issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3

CVE-2019-19481 4.6 - Medium - December 01, 2019

An issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3. libopensc/card-cac1.c mishandles buffer limits for CAC certificates.

Buffer Overflow

An issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3

CVE-2019-19479 5.5 - Medium - December 01, 2019

An issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3. libopensc/card-setcos.c has an incorrect read operation during parsing of a SETCOS file attribute.

Out-of-bounds Read

An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC

CVE-2019-16058 7.5 - High - September 06, 2019

An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.

Buffer Overflow

OpenSC before 0.20.0-rc1 has an out-of-bounds access of an ASN.1 Bitstring in decode_bit_string in libopensc/asn1.c.

CVE-2019-15945 6.4 - Medium - September 05, 2019

OpenSC before 0.20.0-rc1 has an out-of-bounds access of an ASN.1 Bitstring in decode_bit_string in libopensc/asn1.c.

Buffer Overflow

OpenSC before 0.20.0-rc1 has an out-of-bounds access of an ASN.1 Octet string in asn1_decode_entry in libopensc/asn1.c.

CVE-2019-15946 6.4 - Medium - September 05, 2019

OpenSC before 0.20.0-rc1 has an out-of-bounds access of an ASN.1 Octet string in asn1_decode_entry in libopensc/asn1.c.

Buffer Overflow

sc_context_create in ctx.c in libopensc in OpenSC 0.19.0 has a memory leak, as demonstrated by a call

CVE-2019-6502 7.5 - High - January 22, 2019

sc_context_create in ctx.c in libopensc in OpenSC 0.19.0 has a memory leak, as demonstrated by a call from eidenv.

Memory Leak

Various out of bounds reads when handling responses in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to potentially crash the opensc library using programs.

CVE-2018-16427 4.3 - Medium - September 04, 2018

Various out of bounds reads when handling responses in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to potentially crash the opensc library using programs.

Out-of-bounds Read

Endless recursion when handling responses

CVE-2018-16426 4.3 - Medium - September 04, 2018

Endless recursion when handling responses from an IAS-ECC card in iasecc_select_file in libopensc/card-iasecc.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to hang or crash the opensc library using programs.

Stack Exhaustion

A double free when handling responses

CVE-2018-16425 6.6 - Medium - September 04, 2018

A double free when handling responses from an HSM Card in sc_pkcs15emu_sc_hsm_init in libopensc/pkcs15-sc-hsm.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Double-free

A double free when handling responses in read_file in tools/egk-tool.c (aka the eGK card tool) in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

CVE-2018-16424 6.6 - Medium - September 04, 2018

A double free when handling responses in read_file in tools/egk-tool.c (aka the eGK card tool) in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Double-free

A double free when handling responses

CVE-2018-16423 6.6 - Medium - September 04, 2018

A double free when handling responses from a smartcard in sc_file_set_sec_attr in libopensc/sc.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Double-free

A single byte buffer overflow when handling responses

CVE-2018-16422 6.6 - Medium - September 04, 2018

A single byte buffer overflow when handling responses from an esteid Card in sc_pkcs15emu_esteid_init in libopensc/pkcs15-esteid.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Several buffer overflows when handling responses

CVE-2018-16421 6.6 - Medium - September 04, 2018

Several buffer overflows when handling responses from a CAC Card in cac_get_serial_nr_from_CUID in libopensc/card-cac.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Several buffer overflows when handling responses

CVE-2018-16420 6.6 - Medium - September 04, 2018

Several buffer overflows when handling responses from an ePass 2003 Card in decrypt_response in libopensc/card-epass2003.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Several buffer overflows when handling responses

CVE-2018-16419 6.6 - Medium - September 04, 2018

Several buffer overflows when handling responses from a Cryptoflex card in read_public_key in tools/cryptoflex-tool.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

A buffer overflow when handling string concatenation in util_acl_to_str in tools/util.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

CVE-2018-16418 6.6 - Medium - September 04, 2018

A buffer overflow when handling string concatenation in util_acl_to_str in tools/util.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Several buffer overflows when handling responses

CVE-2018-16393 6.8 - Medium - September 03, 2018

Several buffer overflows when handling responses from a Gemsafe V1 Smartcard in gemsafe_get_cert_len in libopensc/pkcs15-gemsafeV1.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Several buffer overflows when handling responses

CVE-2018-16392 6.8 - Medium - September 03, 2018

Several buffer overflows when handling responses from a TCOS Card in tcos_select_file in libopensc/card-tcos.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Several buffer overflows when handling responses

CVE-2018-16391 6.8 - Medium - September 03, 2018

Several buffer overflows when handling responses from a Muscle Card in muscle_list_files in libopensc/card-muscle.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.

Buffer Overflow

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Openscproject Opensc or by Openscproject? Click the Watch button to subscribe.

subscribe