Lxml Lxml

Do you want an email whenever new security vulnerabilities are reported in Lxml?

By the Year

In 2022 there have been 0 vulnerabilities in Lxml . Last year Lxml had 2 security vulnerabilities published. Right now, Lxml is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 2 6.60
2020 1 6.10
2019 0 0.00
2018 1 6.10

It may take a day or so for new Lxml vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Lxml Security Vulnerabilities

lxml is a library for processing XML and HTML in the Python language

CVE-2021-43818 7.1 - High - December 13, 2021

lxml is a library for processing XML and HTML in the Python language. Prior to version 4.6.5, the HTML Cleaner in lxml.html lets certain crafted script content pass through, as well as script content in SVG files embedded using data URIs. Users that employ the HTML cleaner in a security relevant context should upgrade to lxml 4.6.5 to receive a patch. There are no known workarounds available.

XSS

An XSS vulnerability was discovered in python-lxml's clean module versions before 4.6.3

CVE-2021-28957 6.1 - Medium - March 21, 2021

An XSS vulnerability was discovered in python-lxml's clean module versions before 4.6.3. When disabling the safe_attrs_only and forms arguments, the Cleaner class does not remove the formaction attribute allowing for JS to bypass the sanitizer. A remote attacker could exploit this flaw to run arbitrary JS code on users who interact with incorrectly sanitized HTML. This issue is patched in lxml 4.6.3.

XSS

A XSS vulnerability was discovered in python-lxml's clean module

CVE-2020-27783 6.1 - Medium - December 03, 2020

A XSS vulnerability was discovered in python-lxml's clean module. The module's parser didn't properly imitate browsers, which caused different behaviors between the sanitizer and the user's page. A remote attacker could exploit this flaw to run arbitrary HTML/JS code.

XSS

An issue was discovered in lxml before 4.2.5

CVE-2018-19787 6.1 - Medium - December 02, 2018

An issue was discovered in lxml before 4.2.5. lxml/html/clean.py in the lxml.html.clean module does not remove javascript: URLs that use escaping, allowing a remote attacker to conduct XSS attacks, as demonstrated by "j a v a s c r i p t:" in Internet Explorer. This is a similar issue to CVE-2014-3146.

XSS

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Debian Linux or by Lxml? Click the Watch button to subscribe.

Lxml
Vendor

Lxml
Product

subscribe