Libtpms Libtpmsproject Libtpms

Do you want an email whenever new security vulnerabilities are reported in Libtpmsproject Libtpms?

By the Year

In 2021 there have been 4 vulnerabilities in Libtpmsproject Libtpms with an average score of 5.8 out of ten. Libtpms did not have any published security vulnerabilities last year. That is, 4 more vulnerabilities have already been reported in 2021 as compared to last year.

Year Vulnerabilities Average Score
2021 4 5.75
2020 0 0.00
2019 0 0.00
2018 0 0.00

It may take a day or so for new Libtpms vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Libtpmsproject Libtpms Security Vulnerabilities

A flaw was found in the libtpms code that may cause access beyond the boundary of internal buffers

CVE-2021-3746 6.5 - Medium - October 19, 2021

A flaw was found in the libtpms code that may cause access beyond the boundary of internal buffers. The vulnerability is triggered by specially-crafted TPM2 command packets that then trigger the issue when the state of the TPM2's volatile state is written. The highest threat from this vulnerability is to system availability. This issue affects libtpms versions before 0.8.5, before 0.7.9 and before 0.6.6.

Buffer Overflow

A stack corruption bug was found in libtpms in versions before 0.7.2 and before 0.8.0 while decrypting data using RSA

CVE-2021-3569 5.5 - Medium - June 03, 2021

A stack corruption bug was found in libtpms in versions before 0.7.2 and before 0.8.0 while decrypting data using RSA. This flaw could result in a SIGBUS (bad memory access) and termination of swtpm. The highest threat from this vulnerability is to system availability.

Buffer Overflow

A flaw was found in libtpms in versions before 0.8.0

CVE-2021-3505 5.5 - Medium - April 19, 2021

A flaw was found in libtpms in versions before 0.8.0. The TPM 2 implementation returns 2048 bit keys with ~1984 bit strength due to a bug in the TCG specification. The bug is in the key creation algorithm in RsaAdjustPrimeCandidate(), which is called before the prime number check. The highest threat from this vulnerability is to data confidentiality.

Insufficient Entropy

A flaw was found in libtpms in versions before 0.8.2

CVE-2021-3446 5.5 - Medium - March 25, 2021

A flaw was found in libtpms in versions before 0.8.2. The commonly used integration of libtpms with OpenSSL contained a vulnerability related to the returned IV (initialization vector) when certain symmetric ciphers were used. Instead of returning the last IV it returned the initial IV to the caller, thus weakening the subsequent encryption and decryption steps. The highest threat from this vulnerability is to data confidentiality.

Use of a Broken or Risky Cryptographic Algorithm

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Libtpmsproject Libtpms or by Libtpmsproject? Click the Watch button to subscribe.

subscribe