apache log4j CVE-2021-44832 vulnerability in Apache and Other Products
Published on December 28, 2021

product logo product logo product logo product logo product logo product logo
Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2.

Github Repository Vendor Advisory Vendor Advisory NVD

Vulnerability Analysis

CVE-2021-44832 is exploitable with network access, and requires user privileges. This vulnerability is consided to have a high level of attack complexity. It has an exploitability score of 0.7 out of four. The potential impact of an exploit of this vulnerability is considered to be very high.

Improper Input Validation

The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

Products Associated with CVE-2021-44832

You can be notified by stack.watch whenever vulnerabilities like CVE-2021-44832 are published in these products:


What versions are vulnerable to CVE-2021-44832?

Vulnerable Packages

The following package name and versions may be associated with CVE-2021-44832

Package Manager Vulnerable Package Versions Fixed In
maven com.hazelcast.jet:hazelcast-jet >= 4.1, < 4.5.3 4.5.3
maven com.hazelcast:hazelcast >= 5.0, < 5.0.2 5.0.2
maven com.hazelcast:hazelcast < 4.0.5 4.0.5
maven com.hazelcast:hazelcast >= 4.1.1, < 4.1.8 4.1.8
maven com.hazelcast:hazelcast >= 4.2, < 4.2.4 4.2.4