apache log4j CVE-2021-44832 in Apache and Canonical Products
Published on December 28, 2021

product logo product logo
Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2.

Github Repository Vendor Advisory Vendor Advisory NVD

Vulnerability Analysis

CVE-2021-44832 is exploitable with network access, and requires user privileges. This vulnerability is consided to have a high level of attack complexity. It has an exploitability score of 0.7 out of four. The potential impact of an exploit of this vulnerability is considered to be very high.

Improper Input Validation

The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

What is an Injection Vulnerability?

The software constructs all or part of a command, data structure, or record using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify how it is parsed or interpreted when it is sent to a downstream component. Software has certain assumptions about what constitutes data and control respectively. It is the lack of verification of these assumptions for user-controlled input that leads to injection problems. Injection problems encompass a wide variety of issues -- all mitigated in very different ways and usually attempted in order to alter the control flow of the process. For this reason, the most effective way to discuss these weaknesses is to note the distinct features which classify them as injection weaknesses. The most important issue to note is that all injection problems share one thing in common -- i.e., they allow for the injection of control plane data into the user-controlled data plane. This means that the execution of the process may be altered by sending code in through legitimate data channels, using no other mechanism. While buffer overflows, and many other flaws, involve the use of some further issue to gain execution, injection problems need only for the data to be parsed. The most classic instantiations of this category of weakness are SQL injection and format string vulnerabilities.

CVE-2021-44832 has been classified to as an Injection vulnerability or weakness.


Products Associated with CVE-2021-44832

You can be notified by stack.watch whenever vulnerabilities like CVE-2021-44832 are published in these products:

 
 

What versions are vulnerable to CVE-2021-44832?

Vulnerable Packages

The following package name and versions may be associated with CVE-2021-44832

Package Manager Vulnerable Package Versions Fixed In
maven com.hazelcast:hazelcast >= 4.2, < 4.2.4 4.2.4
maven com.hazelcast:hazelcast >= 4.1.1, < 4.1.8 4.1.8
maven com.hazelcast:hazelcast < 4.0.5 4.0.5
maven com.hazelcast:hazelcast >= 5.0, < 5.0.2 5.0.2
maven com.hazelcast.jet:hazelcast-jet >= 4.1, < 4.5.3 4.5.3