CVE-2021-26084 vulnerability in Atlassian Products
Published on August 30, 2021
In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.
Known Exploited Vulnerability
This Atlassian Confluence Server < 6.13.23, 6.14.0 - 7.12.5 Arbitrary Code Execution vulnerability is part of CISA's list of Known Exploited Vulnerabilities. Atlassian Confluence Server The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5 contains an OGNL injection vulnerability which allows an attacker to execute arbitrary code.
The following remediation steps are recommended / required by November 17, 2021: Apply updates per vendor instructions.
CVE-2021-26084 is exploitable with network access, and does not require authorization privileges or user interaction. This vulnerability is considered to have a low attack complexity. It has the highest possible exploitability rating (3.9). The potential impact of an exploit of this vulnerability is considered to be critical as this vulnerability has a high impact to the confidentiality, integrity and availability of this component.
What is an EL Injection Vulnerability?
The software constructs all or part of an expression language (EL) statement in a Java Server Page (JSP) using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the intended EL statement before it is executed.
CVE-2021-26084 has been classified to as an EL Injection vulnerability or weakness.
Products Associated with CVE-2021-26084
You can be notified by stack.watch whenever vulnerabilities like CVE-2021-26084 are published in these products:
What versions are vulnerable to CVE-2021-26084?
- Atlassian Confluence Server Version 7.12.0 Fixed in Version 7.12.5
- Atlassian Confluence Data Center Version 7.12.0 Fixed in Version 7.12.5
- Atlassian Confluence Data Center Version 7.5.0 Fixed in Version 7.11.6
- Atlassian Confluence Data Center Version 6.14.0 Fixed in Version 7.4.11
- Atlassian Confluence Data Center Fixed in Version 6.13.23
- Atlassian Confluence Server Version 6.14.0 Fixed in Version 7.4.11
- Atlassian Confluence Server Version 7.5.0 Fixed in Version 7.11.6
- Atlassian Confluence Server Fixed in Version 6.13.23