Rancher Suse Rancher

Do you want an email whenever new security vulnerabilities are reported in Suse Rancher?

By the Year

In 2022 there have been 4 vulnerabilities in Suse Rancher with an average score of 7.6 out of ten. Last year Rancher had 1 security vulnerability published. That is, 3 more vulnerabilities have already been reported in 2022 as compared to last year. However, the average CVE base score of the vulnerabilities in 2022 is greater by 1.48.

Year Vulnerabilities Average Score
2022 4 7.58
2021 1 6.10
2020 0 0.00
2019 7 7.87
2018 0 0.00

It may take a day or so for new Rancher vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Suse Rancher Security Vulnerabilities

A Missing Encryption of Sensitive Data vulnerability in SUSE Rancher, Rancher

CVE-2022-21951 6.8 - Medium - May 25, 2022

A Missing Encryption of Sensitive Data vulnerability in SUSE Rancher, Rancher allows attackers on the network to read and change network data due to missing encryption of data transmitted via the network when a cluster is created from an RKE template with the CNI value overridden This issue affects: SUSE Rancher Rancher versions prior to 2.5.14; Rancher versions prior to 2.6.5.

Missing Encryption of Sensitive Data

A Improper Privilege Management vulnerability in SUSE Rancher

CVE-2021-4200 8.8 - High - May 02, 2022

A Improper Privilege Management vulnerability in SUSE Rancher allows write access to the Catalog for any user when restricted-admin role is enabled. This issue affects: SUSE Rancher Rancher versions prior to 2.5.13; Rancher versions prior to 2.6.4.

Improper Privilege Management

A Improper Privilege Management vulnerability in SUSE Rancher allows users with the restricted-admin role to escalate to full admin

CVE-2021-36784 7.2 - High - May 02, 2022

A Improper Privilege Management vulnerability in SUSE Rancher allows users with the restricted-admin role to escalate to full admin. This issue affects: SUSE Rancher Rancher versions prior to 2.5.13; Rancher versions prior to 2.6.4.

Improper Privilege Management

A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE Rancher allows administrators of third-party repositories to gather credentials

CVE-2021-36778 7.5 - High - May 02, 2022

A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE Rancher allows administrators of third-party repositories to gather credentials that are sent to their servers. This issue affects: SUSE Rancher Rancher versions prior to 2.5.12; Rancher versions prior to 2.6.3.

Insufficiently Protected Credentials

A Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Rancher

CVE-2021-25313 6.1 - Medium - March 05, 2021

A Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Rancher allows remote attackers to execute JavaScript via malicious links. This issue affects: SUSE Rancher Rancher versions prior to 2.5.6.

XSS

Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack

CVE-2019-13209 6.1 - Medium - September 04, 2019

Rancher 2 through 2.2.4 is vulnerable to a Cross-Site Websocket Hijacking attack that allows an exploiter to gain access to clusters managed by Rancher. The attack requires a victim to be logged into a Rancher server, and then to access a third-party site hosted by the exploiter. Once that is accomplished, the exploiter is able to execute commands against the cluster's Kubernetes API with the permissions and identity of the victim.

XSS

An issue was discovered

CVE-2019-11202 9.8 - Critical - July 30, 2019

An issue was discovered that affects the following versions of Rancher: v2.0.0 through v2.0.13, v2.1.0 through v2.1.8, and v2.2.0 through 2.2.1. When Rancher starts for the first time, it creates a default admin user with a well-known password. After initial setup, the Rancher administrator may choose to delete this default admin user. If Rancher is restarted, the default admin user will be recreated with the well-known default password. An attacker could exploit this by logging in with the default admin credentials. This can be mitigated by deactivating the default admin user rather than completing deleting them.

authentification

A vulnerability exists in Rancher 2.1.4 in the login component, where the errorMsg parameter

CVE-2019-11881 4.7 - Medium - June 10, 2019

A vulnerability exists in Rancher 2.1.4 in the login component, where the errorMsg parameter can be tampered to display arbitrary content, filtering tags but not special characters or symbols. There's no other limitation of the message, allowing malicious users to lure legitimate users to visit phishing sites with scare tactics, e.g., displaying a "This version of Rancher is outdated, please visit https://malicious.rancher.site/upgrading" message.

In Rancher 2 through 2.2.3, Project owners

CVE-2019-12303 8.8 - High - June 06, 2019

In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.

Injection

In Rancher 1 and 2 through 2.2.3, unprivileged users (if

CVE-2019-12274 8.8 - High - June 06, 2019

In Rancher 1 and 2 through 2.2.3, unprivileged users (if allowed to deploy nodes) can gain admin access to the Rancher management plane because node driver options intentionally allow posting certain data to the cloud. The problem is that a user could choose to post a sensitive file such as /root/.kube/config or /var/lib/rancher/management-state/cred/kubeconfig-system.yaml.

Exposure of Resource to Wrong Sphere

In Rancher 2.0.0 through 2.1.5, project members have continued access to create, update, read, and delete namespaces in a project after they have been removed

CVE-2019-6287 8.1 - High - April 10, 2019

In Rancher 2.0.0 through 2.1.5, project members have continued access to create, update, read, and delete namespaces in a project after they have been removed from it.

Improper Privilege Management

An issue was discovered in Rancher 2 through 2.1.5

CVE-2018-20321 8.8 - High - April 10, 2019

An issue was discovered in Rancher 2 through 2.1.5. Any project member with access to the default namespace can mount the netes-default service account in a pod, and then use that pod to execute administrative privileged commands against the k8s cluster. This could be mitigated by isolating the default namespace in a separate project, where only cluster admins can be given permissions to access. As of 2018-12-20, this bug affected ALL clusters created or imported by Rancher.

Exposure of Resource to Wrong Sphere

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call

CVE-2017-7297 8.8 - High - March 29, 2017

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Suse Rancher or by Suse? Click the Watch button to subscribe.

Suse
Vendor

Suse Rancher
Product

subscribe