Global Vpn Client SonicWall Global Vpn Client

Do you want an email whenever new security vulnerabilities are reported in SonicWall Global Vpn Client?

By the Year

In 2022 there have been 1 vulnerability in SonicWall Global Vpn Client with an average score of 7.8 out of ten. Last year Global Vpn Client had 2 security vulnerabilities published. At the current rates, it appears that the number of vulnerabilities last year and this year may equal out. Interestingly, the average vulnerability score and the number of vulnerabilities for 2022 and last year was the same.

Year Vulnerabilities Average Score
2022 1 7.80
2021 2 7.80
2020 2 8.20
2019 0 0.00
2018 0 0.00

It may take a day or so for new Global Vpn Client vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent SonicWall Global Vpn Client Security Vulnerabilities

SonicWall Global VPN Client 4.10.7.1117 installer (32-bit and 64-bit) and earlier versions have a DLL Search Order Hijacking vulnerability in one of the installer components

CVE-2021-20051 7.8 - High - May 04, 2022

SonicWall Global VPN Client 4.10.7.1117 installer (32-bit and 64-bit) and earlier versions have a DLL Search Order Hijacking vulnerability in one of the installer components. Successful exploitation via a local attacker could result in command execution in the target system.

DLL preloading

SonicWall Global VPN client version 4.10.6 (32-bit and 64-bit) and earlier have a DLL Search Order Hijacking vulnerability

CVE-2021-20047 7.8 - High - December 08, 2021

SonicWall Global VPN client version 4.10.6 (32-bit and 64-bit) and earlier have a DLL Search Order Hijacking vulnerability. Successful exploitation via a local attacker could result in remote code execution in the target system.

DLL preloading

SonicWall Global VPN Client 4.10.5 installer (32-bit and 64-bit) incorrect default file permission vulnerability leads to privilege escalation which potentially

CVE-2021-20037 7.8 - High - September 21, 2021

SonicWall Global VPN Client 4.10.5 installer (32-bit and 64-bit) incorrect default file permission vulnerability leads to privilege escalation which potentially allows command execution in the host operating system. This vulnerability impacts GVC 4.10.5 installer and earlier.

Incorrect Default Permissions

SonicWall Global VPN client version 4.10.4.0314 and earlier

CVE-2020-5144 7.8 - High - October 28, 2020

SonicWall Global VPN client version 4.10.4.0314 and earlier allows unprivileged windows user to elevate privileges to SYSTEM through loaded process hijacking vulnerability.

Untrusted Path

SonicWall Global VPN client version 4.10.4.0314 and earlier have an insecure library loading (DLL hijacking) vulnerability

CVE-2020-5145 8.6 - High - October 28, 2020

SonicWall Global VPN client version 4.10.4.0314 and earlier have an insecure library loading (DLL hijacking) vulnerability. Successful exploitation could lead to remote code execution in the target system.

DLL preloading

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for SonicWall Global Vpn Client or by SonicWall? Click the Watch button to subscribe.

SonicWall
Vendor

subscribe