N Central SolarWinds N Central

Do you want an email whenever new security vulnerabilities are reported in SolarWinds N Central?

By the Year

In 2021 there have been 0 vulnerabilities in SolarWinds N Central . Last year N Central had 9 security vulnerabilities published. Right now, N Central is on track to have less security vulnerabilities in 2021 than it did last year.

Year Vulnerabilities Average Score
2021 0 0.00
2020 9 7.56
2019 0 0.00
2018 0 0.00

It may take a day or so for new N Central vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent SolarWinds N Central Security Vulnerabilities

An issue was discovered in SolarWinds N-Central 12.3.0.670

CVE-2020-25620 7.8 - High - December 16, 2020

An issue was discovered in SolarWinds N-Central 12.3.0.670. Hard-coded Credentials exist by default for local user accounts named support@n-able.com and nableadmin@n-able.com. These allow logins to the N-Central Administrative Console (NAC) and/or the regular web interface.

Use of Hard-coded Credentials

An issue was discovered in SolarWinds N-Central 12.3.0.670

CVE-2020-25621 8.4 - High - December 16, 2020

An issue was discovered in SolarWinds N-Central 12.3.0.670. The local database does not require authentication: security is only based on ability to access a network interface. The database has keys and passwords.

authentification

An issue was discovered in SolarWinds N-Central 12.3.0.670

CVE-2020-25622 8.8 - High - December 16, 2020

An issue was discovered in SolarWinds N-Central 12.3.0.670. The AdvancedScripts HTTP endpoint allows CSRF.

Session Riding

An issue was discovered in SolarWinds N-Central 12.3.0.670

CVE-2020-25617 8.8 - High - December 16, 2020

An issue was discovered in SolarWinds N-Central 12.3.0.670. The AdvancedScripts HTTP endpoint allows Relative Path Traversal by an authenticated user of the N-Central Administration Console (NAC), leading to execution of OS commands as root.

Directory traversal

An issue was discovered in SolarWinds N-Central 12.3.0.670

CVE-2020-25618 8.8 - High - December 16, 2020

An issue was discovered in SolarWinds N-Central 12.3.0.670. The sudo configuration has incorrect access control because the nable web user account is effectively able to run arbitrary OS commands as root (i.e., the use of root privileges is not limited to specific programs listed in the sudoers file).

Shell injection

An issue was discovered in SolarWinds N-Central 12.3.0.670

CVE-2020-25619 4.4 - Medium - December 16, 2020

An issue was discovered in SolarWinds N-Central 12.3.0.670. The SSH component does not restrict the Communication Channel to Intended Endpoints. An attacker can leverage an SSH feature (port forwarding with a temporary key pair) to access network services on the 127.0.0.1 interface, even though this feature was only intended for user-to-agent communication.

SolarWinds N-central through 2020.1 allows session hijacking and requires user interaction or physical access

CVE-2020-15909 8.8 - High - October 19, 2020

SolarWinds N-central through 2020.1 allows session hijacking and requires user interaction or physical access. The N-Central JSESSIONID cookie attribute is not checked against multiple sources such as sourceip, MFA claim, etc. as long as the victim stays logged in within N-Central. To take advantage of this, cookie could be stolen and the JSESSIONID can be captured. On its own this is not a surprising result; low security tools allow the cookie to roam from machine to machine. The JSESSION cookie can then be used on the attackers workstation by browsing to the victims NCentral server URL and replacing the JSESSIONID attribute value by the captured value. Expected behavior would be to check this against a second source and enforce at least a reauthentication or multi factor request as N-Central is a highly privileged service.

Session Fixation

SolarWinds N-Central version 12.3 GA and lower does not set the JSESSIONID attribute to HTTPOnly

CVE-2020-15910 4.7 - Medium - October 19, 2020

SolarWinds N-Central version 12.3 GA and lower does not set the JSESSIONID attribute to HTTPOnly. This makes it possible to influence the cookie with javascript. An attacker could send the user to a prepared webpage or by influencing JavaScript to the extract the JESSIONID. This could then be forwarded to the attacker.

Incorrect Permission Assignment for Critical Resource

SolarWinds N-central before 12.1 SP1 HF5 and 12.2 before SP1 HF2

CVE-2020-7984 7.5 - High - January 26, 2020

SolarWinds N-central before 12.1 SP1 HF5 and 12.2 before SP1 HF2 allows remote attackers to retrieve cleartext domain admin credentials from the Agent & Probe settings, and obtain other sensitive information. The attacker can use a customer ID to self register and read any aspects of the agent/appliance configuration.

Cleartext Transmission of Sensitive Information

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for SolarWinds N Central or by SolarWinds? Click the Watch button to subscribe.

subscribe