Plone Plone

Do you want an email whenever new security vulnerabilities are reported in Plone?

By the Year

In 2023 there have been 1 vulnerability in Plone with an average score of 8.8 out of ten. Last year Plone had 1 security vulnerability published. If vulnerabilities keep coming in at the current rate, it appears that number of security vulnerabilities in Plone in 2023 could surpass last years number. However, the average CVE base score of the vulnerabilities in 2023 is greater by 2.70.

Year Vulnerabilities Average Score
2023 1 8.80
2022 1 6.10
2021 12 6.29
2020 10 8.26
2019 0 0.00
2018 0 0.00

It may take a day or so for new Plone vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Plone Security Vulnerabilities

An issue in Plone CMS v

CVE-2021-33926 8.8 - High - February 17, 2023

An issue in Plone CMS v. 5.2.4, 5.2.3, 5.2.2, 5.2.1, 5.2.0, 5.1rc2, 5.1rc1, 5.1b4, 5.1b3, 5.1b2, 5.1a2, 5.1a1, 5.1.7, 5.1.6, 5.1.5, 5.1.4, 5.1.2, 5.1.1 5.1, 5.0rc3, 5.0rc2, 5.0rc1, 5.0.9, 5.0.8, 5.0.7, 5.0.6, 5.0.5, 5.0.4, 5.0.3, 5.0.2, 5.0.10, 5.0.1, 5.0, 4.3.9, 4.3.8, 4.3.7, 4.3.6, 4.3.5, 4.3.4, 4.3.3, 4.3.20, 4 allows attacker to access sensitive information via the RSS feed protlet.

XSPA

Products.ATContentTypes are the core content types for Plone 2.1 - 4.3

CVE-2022-23599 6.1 - Medium - January 28, 2022

Products.ATContentTypes are the core content types for Plone 2.1 - 4.3. Versions of Plone that are dependent on Products.ATContentTypes prior to version 3.0.6 are vulnerable to reflected cross site scripting and open redirect when an attacker can get a compromised version of the image_view_fullscreen page in a cache, for example in Varnish. The technique is known as cache poisoning. Any later visitor can get redirected when clicking on a link on this page. Usually only anonymous users are affected, but this depends on the user's cache settings. Version 3.0.6 of Products.ATContentTypes has been released with a fix. This version works on Plone 5.2, Python 2 only. As a workaround, make sure the image_view_fullscreen page is not stored in the cache. More information about the vulnerability and cvmitigation measures is available in the GitHub Security Advisory.

XSS

In Plone 5.0 through 5.2.4

CVE-2021-35959 5.4 - Medium - June 30, 2021

In Plone 5.0 through 5.2.4, Editors are vulnerable to XSS in the folder contents view, if a Contributor has created a folder with a SCRIPT tag in the description field.

XSS

Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products

CVE-2021-33507 6.1 - Medium - May 21, 2021

Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.

XSS

Plone through 5.2.4 allows XSS via a full name

CVE-2021-33508 5.4 - Medium - May 21, 2021

Plone through 5.2.4 allows XSS via a full name that is mishandled during rendering of the ownership tab of a content item.

XSS

Plone through 5.2.4

CVE-2021-33509 9.9 - Critical - May 21, 2021

Plone through 5.2.4 allows remote authenticated managers to perform disk I/O via crafted keyword arguments to the ReStructuredText transform in a Python script.

Incorrect Permission Assignment for Critical Resource

Plone through 5.2.4

CVE-2021-33510 4.3 - Medium - May 21, 2021

Plone through 5.2.4 allows remote authenticated managers to conduct SSRF attacks via an event ical URL, to read one line of a file.

XSPA

Plone though 5.2.4 allows SSRF via the lxml parser

CVE-2021-33511 7.5 - High - May 21, 2021

Plone though 5.2.4 allows SSRF via the lxml parser. This affects Diazo themes, Dexterity TTW schemas, and modeleditors in plone.app.theming, plone.app.dexterity, and plone.supermodel.

XSPA

Plone through 5.2.4

CVE-2021-33512 5.4 - Medium - May 21, 2021

Plone through 5.2.4 allows stored XSS attacks (by a Contributor) by uploading an SVG or HTML document.

XSS

Plone through 5.2.4

CVE-2021-33513 5.4 - Medium - May 21, 2021

Plone through 5.2.4 allows XSS via the inline_diff methods in Products.CMFDiffTool.

XSS

Zope is an open-source web application server

CVE-2021-32633 8.8 - High - May 21, 2021

Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default, only users with the Manager role can add or edit Zope Page Templates through the web, but sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk from this vulnerability. The problem has been fixed in Zope 5.2 and 4.6. As a workaround, a site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

Directory traversal

Plone CMS until version 5.2.4 has a stored Cross-Site Scripting (XSS) vulnerability in the user fullname property and the file upload functionality

CVE-2021-3313 5.4 - Medium - May 20, 2021

Plone CMS until version 5.2.4 has a stored Cross-Site Scripting (XSS) vulnerability in the user fullname property and the file upload functionality. The user's input data is not properly encoded when being echoed back to the user. This data can be interpreted as executable code by the browser and allows an attacker to execute JavaScript in the context of the victim's browser if the victim opens a vulnerable page containing an XSS payload.

XSS

A stored cross-site scripting (XSS) vulnerability in Plone CMS 5.2.3 exists in site-controlpanel

CVE-2021-29002 5.4 - Medium - March 24, 2021

A stored cross-site scripting (XSS) vulnerability in Plone CMS 5.2.3 exists in site-controlpanel via the "form.widgets.site_title" parameter.

XSS

Products.PluggableAuthService is a pluggable Zope authentication and authorization framework

CVE-2021-21336 6.5 - Medium - March 08, 2021

Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.

Information Disclosure

Plone before 5.2.3 allows XXE attacks via a feature

CVE-2020-28736 8.8 - High - December 30, 2020

Plone before 5.2.3 allows XXE attacks via a feature that is protected by an unapplied permission of plone.schemaeditor.ManageSchemata (therefore, only available to the Manager role).

XXE

Plone before 5.2.3 allows SSRF attacks

CVE-2020-28735 8.8 - High - December 30, 2020

Plone before 5.2.3 allows SSRF attacks via the tracebacks feature (only available to the Manager role).

XSPA

Plone before 5.2.3 allows XXE attacks via a feature

CVE-2020-28734 8.8 - High - December 30, 2020

Plone before 5.2.3 allows XXE attacks via a feature that is explicitly only available to the Manager role.

XXE

The official plone Docker images before version of 4.3.18-alpine (Alpine specific) contain a blank password for a root user

CVE-2020-35190 9.8 - Critical - December 17, 2020

The official plone Docker images before version of 4.3.18-alpine (Alpine specific) contain a blank password for a root user. System using the plone docker container deployed by affected versions of the docker image may allow a remote attacker to achieve root access with a blank password.

Missing Authentication for Critical Function

An XSS issue in the title field in Plone 5.0 through 5.2.1 allows users with a certain privilege level to insert JavaScript

CVE-2020-7937 5.4 - Medium - January 23, 2020

An XSS issue in the title field in Plone 5.0 through 5.2.1 allows users with a certain privilege level to insert JavaScript that will be executed when other users access the site.

XSS

plone.restapi in Plone 5.2.0 through 5.2.1

CVE-2020-7938 8.8 - High - January 23, 2020

plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.

Improper Privilege Management

SQL Injection in DTML or in connection objects in Plone 4.0 through 5.2.1 allows users to perform unwanted SQL queries

CVE-2020-7939 8.8 - High - January 23, 2020

SQL Injection in DTML or in connection objects in Plone 4.0 through 5.2.1 allows users to perform unwanted SQL queries. (This is a problem in Zope.)

SQL Injection

Missing password strength checks on some forms in Plone 4.3 through 5.2.0

CVE-2020-7940 7.5 - High - January 23, 2020

Missing password strength checks on some forms in Plone 4.3 through 5.2.0 allow users to set weak passwords, leading to easier cracking.

Weak Password Requirements

A privilege escalation issue in plone.app.contenttypes in Plone 4.3 through 5.2.1

CVE-2020-7941 9.8 - Critical - January 23, 2020

A privilege escalation issue in plone.app.contenttypes in Plone 4.3 through 5.2.1 allows users to PUT (overwrite) some content without needing write permission.

Improper Privilege Management

An open redirect on the login form (and possibly other places) in Plone 4.0 through 5.2.1 allows an attacker to craft a link to a Plone Site

CVE-2020-7936 6.1 - Medium - January 23, 2020

An open redirect on the login form (and possibly other places) in Plone 4.0 through 5.2.1 allows an attacker to craft a link to a Plone Site that, when followed, and possibly after login, will redirect to an attacker's site.

Open Redirect

The batch id change script (renameObjectsByPaths.py) in Plone before 4.2.3 and 4.3 before beta 1

CVE-2012-5500 - November 03, 2014

The batch id change script (renameObjectsByPaths.py) in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to change the titles of content items by leveraging a valid CSRF token in a crafted request.

Session Riding

The error pages in Plone before 4.2.3 and 4.3 before beta 1

CVE-2012-5508 - November 03, 2014

The error pages in Plone before 4.2.3 and 4.3 before beta 1 allow remote attackers to obtain random numbers and derive the PRNG state for password resets via unspecified vectors. NOTE: this identifier was SPLIT per ADT2 due to different vulnerability types. CVE-2012-6661 was assigned for the PRNG reseeding issue in Zope.

Information Disclosure

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1

CVE-2012-5499 - September 30, 2014

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to cause a denial of service (memory consumption) via a large value, related to formatColumns.

Resource Management Errors

queryCatalog.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to bypass caching

CVE-2012-5498 - September 30, 2014

queryCatalog.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to bypass caching and cause a denial of service via a crafted request to a collection.

Permissions, Privileges, and Access Controls

membership_tool.py in Plone before 4.2.3 and 4.3 before beta 1

CVE-2012-5497 - September 30, 2014

membership_tool.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to enumerate user account names via a crafted URL.

Information Disclosure

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1

CVE-2012-5488 - September 30, 2014

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via a crafted URL, related to createObject.

Code Injection

ZPublisher.HTTPRequest

CVE-2012-5486 - September 30, 2014

ZPublisher.HTTPRequest._scrubHeader in Zope 2 before 2.13.19, as used in Plone before 4.3 beta 1, allows remote attackers to inject arbitrary HTTP headers via a linefeed (LF) character.

registerConfiglet.py in Plone before 4.2.3 and 4.3 before beta 1

CVE-2012-5485 - September 30, 2014

registerConfiglet.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via unspecified vectors, related to the admin interface.

Code Injection

The isURLInPortal method in the URLTool class in in_portal.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 treats URLs starting with a space as a relative URL, which

CVE-2013-4200 - January 21, 2014

The isURLInPortal method in the URLTool class in in_portal.py in Plone 2.1 through 4.1, 4.2.x through 4.2.5, and 4.3.x through 4.3.1 treats URLs starting with a space as a relative URL, which allows remote attackers to bypass the allow_external_login_sites filtering property, redirect users to arbitrary web sites, and conduct phishing attacks via a space before a URL in the "next" parameter to acl_users/credentials_cookie_auth/require_login.

Permissions, Privileges, and Access Controls

Cross-site scripting (XSS) vulnerability in Plone 4.1 and earlier

CVE-2011-1948 - June 06, 2011

Cross-site scripting (XSS) vulnerability in Plone 4.1 and earlier allows remote attackers to inject arbitrary web script or HTML via a crafted URL.

XSS

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Plone or by Plone? Click the Watch button to subscribe.

Plone
Vendor

Plone
Product

subscribe