Lodash Lodash

Do you want an email whenever new security vulnerabilities are reported in Lodash?

By the Year

In 2022 there have been 0 vulnerabilities in Lodash . Last year Lodash had 2 security vulnerabilities published. Right now, Lodash is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 2 6.25
2020 1 7.40
2019 3 7.07
2018 1 6.50

It may take a day or so for new Lodash vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Lodash Security Vulnerabilities

Lodash versions prior to 4.17.21 are vulnerable to Command Injection

CVE-2021-23337 7.2 - High - February 15, 2021

Lodash versions prior to 4.17.21 are vulnerable to Command Injection via the template function.

Command Injection

Lodash versions prior to 4.17.21 are vulnerable to Regular Expression Denial of Service (ReDoS)

CVE-2020-28500 5.3 - Medium - February 15, 2021

Lodash versions prior to 4.17.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the toNumber, trim and trimEnd functions.

Prototype pollution attack when using _.zipObjectDeep in lodash before 4.17.20.

CVE-2020-8203 7.4 - High - July 15, 2020

Prototype pollution attack when using _.zipObjectDeep in lodash before 4.17.20.

Prototype Pollution

Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution

CVE-2019-10744 9.1 - Critical - July 26, 2019

Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.

lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption

CVE-2019-1010266 6.5 - Medium - July 17, 2019

lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.

Resource Exhaustion

A prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep

CVE-2018-16487 5.6 - Medium - February 01, 2019

A prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked into adding or modifying properties of Object.prototype.

lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property

CVE-2018-3721 6.5 - Medium - June 07, 2018

lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Lodash or by Lodash? Click the Watch button to subscribe.

Lodash
Vendor

Lodash
Product

subscribe