Ledgersmb Ledgersmb

Do you want an email whenever new security vulnerabilities are reported in Ledgersmb?

By the Year

In 2021 there have been 4 vulnerabilities in Ledgersmb with an average score of 7.7 out of ten. Ledgersmb did not have any published security vulnerabilities last year. That is, 4 more vulnerabilities have already been reported in 2021 as compared to last year.

Year Vulnerabilities Average Score
2021 4 7.68
2020 0 0.00
2019 0 0.00
2018 1 9.80

It may take a day or so for new Ledgersmb vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Ledgersmb Security Vulnerabilities

LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy

CVE-2021-3882 6.8 - Medium - October 14, 2021

LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy. By tricking a user to use an unencrypted connection (HTTP), an attacker may be able to obtain the authentication data by capturing network traffic. LedgerSMB 1.8 and newer switched from Basic authentication to using cookie authentication with encrypted cookies. Although an attacker can't access the information inside the cookie, nor the password of the user, possession of the cookie is enough to access the application as the user from which the cookie has been obtained. In order for the attacker to obtain the cookie, first of all the server must be configured to respond to unencrypted requests, the attacker must be suitably positioned to eavesdrop on the network traffic between the client and the server *and* the user must be tricked into using unencrypted HTTP traffic. Proper audit control and separation of duties limit Integrity impact of the attack vector. Users of LedgerSMB 1.8 are urged to upgrade to known-fixed versions. Users of LedgerSMB 1.7 or 1.9 are unaffected by this vulnerability and don't need to take action. As a workaround, users may configure their Apache or Nginx reverse proxy to add the Secure attribute at the network boundary instead of relying on LedgerSMB. For Apache, please refer to the 'Header always edit' configuration command in the mod_headers module. For Nginx, please refer to the 'proxy_cookie_flags' configuration command.

Missing Encryption of Sensitive Data

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM

CVE-2021-3693 9.6 - Critical - August 23, 2021

LedgerSMB does not check the origin of HTML fragments merged into the browser's DOM. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

XSS

LedgerSMB does not sufficiently guard against being wrapped by other sites, making it vulnerable to 'clickjacking'

CVE-2021-3731 4.7 - Medium - August 23, 2021

LedgerSMB does not sufficiently guard against being wrapped by other sites, making it vulnerable to 'clickjacking'. This allows an attacker to trick a targetted user to execute unintended actions.

Clickjacking

LedgerSMB does not sufficiently HTML-encode error messages sent to the browser

CVE-2021-3694 9.6 - Critical - August 23, 2021

LedgerSMB does not sufficiently HTML-encode error messages sent to the browser. By sending a specially crafted URL to an authenticated user, this flaw can be abused for remote code execution and information disclosure.

XSS

The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through 1.5.x, insufficiently sanitizes or escapes variable values used as part of shell command execution, resulting in shell code injection

CVE-2018-9246 9.8 - Critical - June 08, 2018

The PGObject::Util::DBAdmin module before 0.120.0 for Perl, as used in LedgerSMB through 1.5.x, insufficiently sanitizes or escapes variable values used as part of shell command execution, resulting in shell code injection via the create(), run_file(), backup(), or restore() function. The vulnerability allows unauthorized users to execute code with the same privileges as the running application.

Output Sanitization

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Pgobject Util Dbadminproject Pgobject Util Dbadmin or by Ledgersmb? Click the Watch button to subscribe.

Ledgersmb
Vendor

Ledgersmb
Product

subscribe