Spectrum Protect Operations Center IBM Spectrum Protect Operations Center

stack.watch can email you when security vulnerabilities are reported in IBM Spectrum Protect Operations Center. You can add multiple products that you use with Spectrum Protect Operations Center to create your own personal software stack watcher.

By the Year

In 2021 there have been 3 vulnerabilities in IBM Spectrum Protect Operations Center with an average score of 6.1 out of ten. Spectrum Protect Operations Center did not have any published security vulnerabilities last year. That is, 3 more vulnerabilities have already been reported in 2021 as compared to last year.

Year Vulnerabilities Average Score
2021 3 6.07
2020 0 0.00
2019 3 7.63
2018 0 0.00

It may take a day or so for new Spectrum Protect Operations Center vulnerabilities to show up. Additionally vulnerabilities may be tagged under a different product or component name.

Latest IBM Spectrum Protect Operations Center Security Vulnerabilities

IBM Spectrum Protect Operations Center 7.1 and 8.1 could

CVE-2020-4954 5.4 - Medium - February 15, 2021

IBM Spectrum Protect Operations Center 7.1 and 8.1 could allow a remote attacker to bypass authentication restrictions, caused by improper session validation . By using the configuration panel to obtain a valid session using an attacker controlled IBM Spectrum Protect server, an attacker could exploit this vulnerability to bypass authentication and gain access to a limited number of debug functions, such as logging levels. IBM X-Force ID: 192153.

384

IBM Spectrum Protect Operations Center 7.1 and 8.1could

CVE-2020-4955 8 - High - February 15, 2021

IBM Spectrum Protect Operations Center 7.1 and 8.1could allow a remote attacker to execute arbitrary code on the system, caused by improper parameter validation. By creating an unspecified servlet request with specially crafted input parameters, an attacker could exploit this vulnerability to load a malicious .dll with elevated privileges. IBM X-Force ID: 192155.

Unrestricted File Upload

IBM Spectrum Protect Operations Center 7.1 and 8.1 is vulnerable to a denial of service, caused by a RPC

CVE-2020-4956 4.8 - Medium - February 15, 2021

IBM Spectrum Protect Operations Center 7.1 and 8.1 is vulnerable to a denial of service, caused by a RPC that allows certain cache values to be set and dumped to a file. By setting a grossly large cache value and dumping that cached value to a file multiple times, a remote attacker could exploit this vulnerability to cause the consumption of all memory resources. IBM X-Force ID: 192156.

Uncontrolled Resource Consumption ('Resource Exhaustion')

IBM Spectrum Protect Servers 7.1 and 8.1 and Storage Agents are vulnerable to a stack-based buffer overflow

CVE-2019-4087 9.8 - Critical - July 02, 2019

IBM Spectrum Protect Servers 7.1 and 8.1 and Storage Agents are vulnerable to a stack-based buffer overflow, caused by improper bounds checking by servers and storage agents in response to specifically crafted communication exchanges. By sending an overly long request, a remote attacker could overflow a buffer and execute arbitrary code on the system with instance id privileges or cause the server or storage agent to crash. IBM X-Force ID: 157510.

CVE-2019-4087 can be explotited with network access, and does not require authorization privledges or user interaction. This vulnerability is considered to have a low attack complexity. It has the highest possible exploitability rating (3.9). The potential impact of an exploit of this vulnerability is considered to be critical as this vulneraility has a high impact to the confidentiality, integrity and availability of this component.

Out-of-bounds Write

IBM Spectrum Protect Servers 7.1 and 8.1 and Storage Agents could

CVE-2019-4088 7.8 - High - July 02, 2019

IBM Spectrum Protect Servers 7.1 and 8.1 and Storage Agents could allow a local attacker to gain elevated privileges on the system, caused by loading a specially crafted library loaded by the dsmqsan module. By setting up such a library, a local attacker could exploit this vulnerability to gain root privileges on the vulnerable system. IBM X-Force ID: 157511.

CVE-2019-4088 is exploitable with local system access, and requires small amount of user privledges. This vulnerability is considered to have a low attack complexity. It has an exploitability score of 1.8 out of four. The potential impact of an exploit of this vulnerability is considered to be very high.

IBM Spectrum Protect Operations Center 7.1 and 8.1 could

CVE-2019-4129 5.3 - Medium - July 02, 2019

IBM Spectrum Protect Operations Center 7.1 and 8.1 could allow a remote attacker to obtain sensitive information, caused by an error message containing a stack trace. By creating an error with a stack trace, an attacker could exploit this vulnerability to potentially obtain details on the Operations Center architecture. IBM X-Force ID: 158279.

CVE-2019-4129 can be explotited with network access, and does not require authorization privledges or user interaction. This vulnerability is considered to have a low attack complexity. It has the highest possible exploitability rating (3.9). The potential impact of an exploit of this vulnerability is considered to have a small impact on confidentiality, a small impact on integrity and availability.

Information Exposure Through an Error Message