Peripheral Manager Dell Peripheral Manager

Do you want an email whenever new security vulnerabilities are reported in Dell Peripheral Manager?

By the Year

In 2022 there have been 0 vulnerabilities in Dell Peripheral Manager . Last year Peripheral Manager had 1 security vulnerability published. Right now, Peripheral Manager is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 1 7.80
2020 0 0.00
2019 0 0.00
2018 0 0.00

It may take a day or so for new Peripheral Manager vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Dell Peripheral Manager Security Vulnerabilities

Dell Peripheral Manager 1.3.1 or greater contains remediation for a local privilege escalation vulnerability

CVE-2021-21545 7.8 - High - April 12, 2021

Dell Peripheral Manager 1.3.1 or greater contains remediation for a local privilege escalation vulnerability that could be potentially exploited to gain arbitrary code execution on the system with privileges of the system user.

DLL preloading

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Dell Peripheral Manager or by Dell? Click the Watch button to subscribe.

Dell
Vendor

subscribe