Emc Unityvsa Operating Environment Dell Emc Unityvsa Operating Environment

Do you want an email whenever new security vulnerabilities are reported in Dell Emc Unityvsa Operating Environment?

By the Year

In 2022 there have been 1 vulnerability in Dell Emc Unityvsa Operating Environment with an average score of 6.7 out of ten. Last year Emc Unityvsa Operating Environment had 3 security vulnerabilities published. Right now, Emc Unityvsa Operating Environment is on track to have less security vulnerabilities in 2022 than it did last year. Interestingly, the average vulnerability score and the number of vulnerabilities for 2022 and last year was the same.

Year Vulnerabilities Average Score
2022 1 6.70
2021 3 6.70
2020 1 7.50
2019 3 6.07
2018 3 7.03

It may take a day or so for new Emc Unityvsa Operating Environment vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Dell Emc Unityvsa Operating Environment Security Vulnerabilities

Dell EMC Unity

CVE-2021-43589 6.7 - Medium - January 24, 2022

Dell EMC Unity, Dell EMC UnityVSA and Dell EMC Unity XT versions prior to 5.1.2.0.5.007 contain an operating system (OS) command injection Vulnerability. A locally authenticated user with high privileges may potentially exploit this vulnerability, leading to the execution of arbitrary OS commands on the Unity underlying OS, with the privileges of the vulnerable application. Exploitation may lead to an elevation of privilege.

Shell injection

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 contain a plain-text password storage vulnerability

CVE-2021-21591 6.7 - Medium - July 12, 2021

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 contain a plain-text password storage vulnerability. A local malicious user with high privileges may use the exposed password to gain access with the privileges of the compromised user.

Information Disclosure

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 contain a plain-text password storage vulnerability

CVE-2021-21590 6.7 - Medium - July 12, 2021

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 contain a plain-text password storage vulnerability. A local malicious user with high privileges may use the exposed password to gain access with the privileges of the compromised user.

Information Disclosure

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 do not exit on failed Initialization

CVE-2021-21589 6.7 - Medium - July 12, 2021

Dell EMC Unity, Unity XT, and UnityVSA versions prior to 5.1.0.0.5.394 do not exit on failed Initialization. A local authenticated Service user could potentially exploit this vulnerability to escalate privileges.

Dell EMC Unity, Dell EMC Unity XT, and Dell EMC UnityVSA versions prior to 5.0.2.0.5.009 contain a Denial of Service vulnerability on NAS Server SSH implementation

CVE-2020-5319 7.5 - High - February 06, 2020

Dell EMC Unity, Dell EMC Unity XT, and Dell EMC UnityVSA versions prior to 5.0.2.0.5.009 contain a Denial of Service vulnerability on NAS Server SSH implementation that is used to provide SFTP service on a NAS server. A remote unauthenticated attacker may potentially exploit this vulnerability and cause a Denial of Service (Storage Processor Panic) by sending an out of order SSH protocol sequence.

out-of-bounds array index

Dell EMC Unity Operating Environment versions prior to 5.0.0.0.5.116

CVE-2019-3754 6.1 - Medium - September 03, 2019

Dell EMC Unity Operating Environment versions prior to 5.0.0.0.5.116, Dell EMC UnityVSA versions prior to 5.0.0.0.5.116 and Dell EMC VNXe3200 versions prior to 3.1.10.9946299 contain a reflected cross-site scripting vulnerability on the cas/logout page. A remote unauthenticated attacker could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or Java Script code to Unisphere, which is then reflected back to the victim and executed by the web browser.

XSS

Dell EMC Unity and UnityVSA versions prior to 5.0.0.0.5.116 contain an improper authorization vulnerability in NAS Server quotas configuration

CVE-2019-3734 4.3 - Medium - July 18, 2019

Dell EMC Unity and UnityVSA versions prior to 5.0.0.0.5.116 contain an improper authorization vulnerability in NAS Server quotas configuration. A remote authenticated Unisphere Operator could potentially exploit this vulnerability to edit quota configuration of other users.

Dell EMC Unity and UnityVSA versions prior to 5.0.0.0.5.116 contain a plain-text password storage vulnerability

CVE-2019-3741 7.8 - High - July 18, 2019

Dell EMC Unity and UnityVSA versions prior to 5.0.0.0.5.116 contain a plain-text password storage vulnerability. A Unisphere users (including the admin privilege user) password is stored in a plain text in Unity Data Collection bundle (logs files for troubleshooting). A local authenticated attacker with access to the Data Collection bundle may use the exposed password to gain access with the privileges of the compromised user.

Protection Mechanism Failure

Dell EMC Unity OE versions 4.3.0.x and 4.3.1.x and UnityVSA OE versions 4.3.0.x and 4.3.1.x contains an Incorrect File Permissions vulnerability

CVE-2018-11064 7.8 - High - October 05, 2018

Dell EMC Unity OE versions 4.3.0.x and 4.3.1.x and UnityVSA OE versions 4.3.0.x and 4.3.1.x contains an Incorrect File Permissions vulnerability. A locally authenticated malicious user could potentially exploit this vulnerability to alter multiple library files in service tools that might result in arbitrary code execution with elevated privileges. No user file systems are directly affected by this vulnerability.

Incorrect Permission Assignment for Critical Resource

Dell EMC Unity and UnityVSA contains reflected cross-site scripting vulnerability

CVE-2018-1246 6.1 - Medium - September 28, 2018

Dell EMC Unity and UnityVSA contains reflected cross-site scripting vulnerability. A remote unauthenticated attacker could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or Java Script code to Unisphere, which is then reflected back to the victim and executed by the web browser.

XSS

Dell EMC Unity Operating Environment (OE) versions prior to 4.3.0.1522077968 are affected by multiple OS command injection vulnerabilities

CVE-2018-1239 7.2 - High - May 08, 2018

Dell EMC Unity Operating Environment (OE) versions prior to 4.3.0.1522077968 are affected by multiple OS command injection vulnerabilities. A remote application admin user could potentially exploit the vulnerabilities to execute arbitrary OS commands as system root on the system where Dell EMC Unity is installed.

Shell injection

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Dell Emc Unity Operating Environment or by Dell? Click the Watch button to subscribe.

Dell
Vendor

subscribe