Emc Networker Dell Emc Networker

Do you want an email whenever new security vulnerabilities are reported in Dell Emc Networker?

By the Year

In 2022 there have been 0 vulnerabilities in Dell Emc Networker . Last year Emc Networker had 7 security vulnerabilities published. Right now, Emc Networker is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 7 5.61
2020 2 6.50
2019 0 0.00
2018 2 8.15

It may take a day or so for new Emc Networker vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Dell Emc Networker Security Vulnerabilities

Dell EMC Networker versions prior to 19.5 contain an Improper Authorization vulnerability

CVE-2021-36311 7.8 - High - November 23, 2021

Dell EMC Networker versions prior to 19.5 contain an Improper Authorization vulnerability. Any local malicious user with networker user privileges may exploit this vulnerability to upload malicious file to unauthorized locations and execute it.

AuthZ

Dell NetWorker, versions 18.x and 19.x contain an Information disclosure vulnerability

CVE-2021-21570 4.9 - Medium - September 28, 2021

Dell NetWorker, versions 18.x and 19.x contain an Information disclosure vulnerability. A NetWorker server user with remote access to NetWorker clients may potentially exploit this vulnerability and gain access to unauthorized information.

Shell injection

Dell NetWorker, versions 18.x and 19.x contain a Path traversal vulnerability

CVE-2021-21569 4.9 - Medium - September 28, 2021

Dell NetWorker, versions 18.x and 19.x contain a Path traversal vulnerability. A NetWorker server user with remote access to NetWorker clients may potentially exploit this vulnerability and gain access to unauthorized information.

Directory traversal

Dell EMC NetWorker, 19.4 or older, contain an uncontrolled resource consumption flaw in its API service

CVE-2021-21600 6.5 - Medium - August 10, 2021

Dell EMC NetWorker, 19.4 or older, contain an uncontrolled resource consumption flaw in its API service. An authorized API user could potentially exploit this vulnerability via the web and desktop user interfaces, leading to denial of service in the manageability path.

Missing Release of Resource after Effective Lifetime

Dell EMC NetWorker versions 18.x,19.x prior to 19.3.0.4 and 19.4.0.0 contain an Information Disclosure in Log Files vulnerability

CVE-2021-21546 5.5 - Medium - July 29, 2021

Dell EMC NetWorker versions 18.x,19.x prior to 19.3.0.4 and 19.4.0.0 contain an Information Disclosure in Log Files vulnerability. A local low-privileged user of the Networker server could potentially exploit this vulnerability to read plain-text credentials from server log files.

Insertion of Sensitive Information into Log File

Dell EMC NetWorker, versions 18.x, 19.1.x, 19.2.x 19.3.x, 19.4, and 19.4.0.1 contain an Improper Certificate Validation vulnerability in the client (NetWorker Management Console) components

CVE-2021-21559 5.3 - Medium - June 08, 2021

Dell EMC NetWorker, versions 18.x, 19.1.x, 19.2.x 19.3.x, 19.4, and 19.4.0.1 contain an Improper Certificate Validation vulnerability in the client (NetWorker Management Console) components which uses SSL encrypted connection in order to communicate with the application server. An unauthenticated attacker in the same network collision domain as the NetWorker Management Console client could potentially exploit this vulnerability to perform man-in-the-middle attacks to intercept and tamper the traffic between the client and the application server.

Improper Certificate Validation

Dell EMC NetWorker, 18.x, 19.1.x, 19.2.x 19.3.x, 19.4 and 19.4.0.1, contains an Information Disclosure vulnerability

CVE-2021-21558 4.4 - Medium - June 08, 2021

Dell EMC NetWorker, 18.x, 19.1.x, 19.2.x 19.3.x, 19.4 and 19.4.0.1, contains an Information Disclosure vulnerability. A local administrator of the gstd system may potentially exploit this vulnerability to read LDAP credentials from local logs and use the stolen credentials to make changes to the network domain.

Insertion of Sensitive Information into Log File

Dell EMC NetWorker versions prior to 19.3.0.2 contain an incorrect privilege assignment vulnerability

CVE-2020-26182 6.5 - Medium - October 16, 2020

Dell EMC NetWorker versions prior to 19.3.0.2 contain an incorrect privilege assignment vulnerability. A non-LDAP remote user with low privileges may exploit this vulnerability to perform 'saveset' related operations in an unintended manner. The vulnerability is not exploitable by users authenticated via LDAP.

Files or Directories Accessible to External Parties

Dell EMC NetWorker versions prior to 19.3.0.2 contain an improper authorization vulnerability

CVE-2020-26183 6.5 - Medium - October 16, 2020

Dell EMC NetWorker versions prior to 19.3.0.2 contain an improper authorization vulnerability. Certain remote users with low privileges may exploit this vulnerability to perform 'nsrmmdbd' operations in an unintended manner.

Files or Directories Accessible to External Parties

Dell EMC NetWorker versions between 9.0 and 9.1.1.8 through 9.2.1.3

CVE-2018-11050 8.8 - High - August 01, 2018

Dell EMC NetWorker versions between 9.0 and 9.1.1.8 through 9.2.1.3, and the version 18.1.0.1 contain a Clear-Text authentication over network vulnerability in the Rabbit MQ Advanced Message Queuing Protocol (AMQP) component. User credentials are sent unencrypted to the remote AMQP service. An unauthenticated attacker in the same network collision domain, could potentially sniff the password from the network and use it to access the component using the privileges of the compromised user.

Insufficiently Protected Credentials

In Dell EMC NetWorker versions prior to 9.2.1.1

CVE-2018-1218 7.5 - High - March 19, 2018

In Dell EMC NetWorker versions prior to 9.2.1.1, versions prior to 9.1.1.6, 9.0.x, and versions prior to 8.2.4.11, the 'nsrd' daemon causes a buffer overflow condition when handling certain messages. A remote unauthenticated attacker could potentially exploit this vulnerability to cause a denial of service to the users of NetWorker systems.

Buffer Overflow

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Dell Emc Networker or by Dell? Click the Watch button to subscribe.

Dell
Vendor

subscribe