Auth0 Js Auth0 Js

Don't miss out!

Thousands of developers use stack.watch to stay informed.
Get an email whenever new security vulnerabilities are reported in Auth0 Js.

By the Year

In 2026 there have been 0 vulnerabilities in Auth0 Js. Auth0 Js did not have any published security vulnerabilities last year.

Year Vulnerabilities Average Score
2026 0 0.00
2025 0 0.00
2024 0 0.00
2023 0 0.00
2022 0 0.00
2021 0 0.00
2020 1 4.90
2019 0 0.00
2018 3 0.00

It may take a day or so for new Auth0 Js vulnerabilities to show up in the stats or in the list of recent security vulnerabilities. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Auth0 Js Security Vulnerabilities

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability
CVE-2020-5263 4.9 - Medium - April 09, 2020

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

Insufficiently Protected Credentials

The Auth0 authentication service before 2017-10-15
CVE-2018-6873 - April 04, 2018

The Auth0 authentication service before 2017-10-15 allows privilege escalation because the JWT audience is not validated.

CSRF exists in the Auth0 authentication service through 14591 if the Legacy Lock API flag is enabled.
CVE-2018-6874 - April 04, 2018

CSRF exists in the Auth0 authentication service through 14591 if the Legacy Lock API flag is enabled.

The Auth0 Auth0.js library before 9.3 has CSRF
CVE-2018-7307 - March 06, 2018

The Auth0 Auth0.js library before 9.3 has CSRF because it mishandles the case where the authorization response lacks the state parameter.

A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12
CVE-2017-17068 7.5 - High - December 06, 2017

A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().

Information Disclosure

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Auth0 Js or by Auth0? Click the Watch button to subscribe.

Auth0
Vendor

Auth0 Js
Product

subscribe