Premiere Elements Adobe Premiere Elements

Do you want an email whenever new security vulnerabilities are reported in Adobe Premiere Elements?

By the Year

In 2022 there have been 0 vulnerabilities in Adobe Premiere Elements . Last year Premiere Elements had 1 security vulnerability published. Right now, Premiere Elements is on track to have less security vulnerabilities in 2022 than it did last year.

Year Vulnerabilities Average Score
2022 0 0.00
2021 1 7.80
2020 0 0.00
2019 0 0.00
2018 0 0.00

It may take a day or so for new Premiere Elements vulnerabilities to show up in the stats or in the list of recent security vulnerabilties. Additionally vulnerabilities may be tagged under a different product or component name.

Recent Adobe Premiere Elements Security Vulnerabilities

Adobe Premiere Elements version 2021.2235820 (and earlier) is affected by a memory corruption vulnerability due to insecure handling of a malicious png file

CVE-2021-39824 7.8 - High - September 27, 2021

Adobe Premiere Elements version 2021.2235820 (and earlier) is affected by a memory corruption vulnerability due to insecure handling of a malicious png file, potentially resulting in arbitrary code execution in the context of the current user. User interaction is required to exploit this vulnerability.

Buffer Overflow

Stay on top of Security Vulnerabilities

Want an email whenever new vulnerabilities are published for Adobe Premiere Elements or by Adobe? Click the Watch button to subscribe.

Adobe
Vendor

subscribe