Discourse oEmbed Trust Bypass via Allowlisted iframe (pre-2026.9.0)
CVE-2026-91159 Published on October 14, 2026
Discourse: Stored oEmbed HTML injection via allowed iframe
Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.
Vulnerability Analysis
CVE-2026-91159 can be exploited with network access, and requires small amount of user privileges. This vulnerability is considered to have a low attack complexity. The potential impact of an exploit of this vulnerability is considered to have no impact on confidentiality, a high impact on integrity, and no impact on availability.
Weakness Type
What is a XSS Vulnerability?
The software does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.
CVE-2026-91159 has been classified to as a XSS vulnerability or weakness.
Products Associated with CVE-2026-91159
Want to know whenever a new CVE is published for Discourse? stack.watch will email you.
Affected Versions
discourse:- Version < 2026.1.9 is affected.
- Version >= 2026.7.0-latest, < 2026.7.3 is affected.
- Version >= 2026.8.0-latest, < 2026.8.1 is affected.
- Version >= 2026.9.0-latest, < 2026.9.0 is affected.