Apache WSS4J EncryptedHeader Child Confusion Bypass (3.0.6,4.0.2)
CVE-2026-89238 Published on September 30, 2026
Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection
WSS4J EncryptedHeader child confusion could promote an attacker-controlled plaintext element as the decrypted header, leading to incorrect confidentiality coverage and possible policy bypass.
Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Vulnerability Analysis
CVE-2026-89238 is exploitable with network access, and does not require authorization privileges or user interaction. This vulnerability is considered to have a low attack complexity. The potential impact of an exploit of this vulnerability is considered to have a high impact on confidentiality and integrity, and no impact on availability.
Weakness Type
Insufficient Verification of Data Authenticity
The software does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.
Products Associated with CVE-2026-89238
Want to know whenever a new CVE is published for Apache Wss4j? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache WSS4J:- Version 4.0.0 and below 4.0.2 is affected.
- Version 3.0.0 and below 3.0.6 is affected.
- Before 2.4.4 is affected.