Apache Camel HTTP Component Access Control Bypass (4.0.0-4.18.5, 4.19.0-4.22.1)
CVE-2026-85316 Published on October 19, 2026
Apache Camel: Camel-Platform-HTTP Unintended Proxy Mode via Prefix Path Matching
Insufficient Granularity of Access Control vulnerability in Apache Camel Platform HTTP component.
This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.
The component decided whether an endpoint ran in proxy mode by testing whether its configured path started with the string proxy, rather than by matching the path exactly. Any endpoint whose path merely begins with those characters - proxyStatus, proxy-config, proxying and so on - therefore became a proxy endpoint without the route author asking for it. A proxy endpoint forwards requests onward, so an endpoint that was intended to serve its own content instead relays traffic on behalf of whoever calls it, which is both a request forgery primitive and an exposure of whatever the forwarding path can reach.
Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. Proxy mode is now selected by an exact path match rather than by prefix. For deployments that cannot upgrade immediately, rename any endpoint path that begins with proxy but is not intended to be a proxy.
Vulnerability Analysis
CVE-2026-85316 is exploitable with network access, and does not require authorization privileges or user interaction. This vulnerability is consided to have a high level of attack complexity. The potential impact of an exploit of this vulnerability is considered to have a small impact on confidentiality and integrity, and no impact on availability.
Weakness Type
Insufficient Granularity of Access Control
The product implements access controls via a policy or other feature with the intention to disable or restrict accesses (reads and/or writes) to assets in a system from untrusted agents. However, implemented access controls lack required granularity, which renders the control policy too broad because it allows accesses from unauthorized agents to the security-sensitive assets.
Products Associated with CVE-2026-85316
Want to know whenever a new CVE is published for Apache Camel? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache Camel:- Version 4.0.0 and below 4.18.5 is affected.
- Version 4.19.0 and below 4.22.1 is affected.
- Version 4.18.5 is unaffected.
- Version 4.22.1 is unaffected.
- Version 4.23.0 is unaffected.