CVE-2026-83525 is a vulnerability in Apache Kafka
Published on October 28, 2026
Apache Kafka: Incorrect boolean operator in FetchSnapshot RPC handler allows authenticated network clients to crash the KRaft controller via a malformed request.
Incorrect operator (CWE-480) in the FetchSnapshot RPC handler
in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2
on all platforms allows an authenticated attacker with
CLUSTER_ACTION privilege to cause a denial of service
(controller process termination) via a crafted
FetchSnapshotRequest with an empty topics array or a topic
with no partitions.
Users are recommended to upgrade to version 4.2.2, 4.3.2, or
4.4.0, which fix this issue. Users on unsupported branches
(4.1.x and earlier) should upgrade to 4.2.2 or later.
Weakness Type
Use of Incorrect Operator
The programmer accidentally uses the wrong operator, which changes the application logic in security-relevant ways. These types of errors are generally the result of a typo.
Products Associated with CVE-2026-83525
Want to know whenever a new CVE is published for Apache Kafka? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache Kafka:- Version 2.8.0 and below 4.2.2 is affected.
- Version 4.3.0 and below 4.3.2 is affected.