Apache Kylin 4.x-5.0.4 CrossProject Job Manipulation Allowing Unauthorized Access
CVE-2026-69077 Published on October 16, 2026
Apache Kylin: JobController allows unauthorized cross-project manipulation
Exposure of unauthorized cross-project job manipulation vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted.
This issue affects Apache Kylin: from 4 through 5.0.4.
Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Vulnerability Analysis
CVE-2026-69077 can be exploited with network access, and does not require authorization privileges or user interaction. This vulnerability is considered to have a low attack complexity. The potential impact of an exploit of this vulnerability is considered to have a high impact on confidentiality, with no impact on integrity and availability.
Weakness Type
What is an Information Disclosure Vulnerability?
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
CVE-2026-69077 has been classified to as an Information Disclosure vulnerability or weakness.
Products Associated with CVE-2026-69077
Want to know whenever a new CVE is published for Apache Kylin? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache Kylin:- Version 4..0.0, <= 5.0.4 is affected.