Apache Kylin Deserialization Vulnerability (4-5.0.4)
CVE-2026-64610 Published on October 16, 2026
Apache Kylin: Redis unsafe Java deserialization
Deserialization of Untrusted Data vulnerability in Apache Kylin. Unsafe Java deserialization could happen from a broken external cache service.
This issue affects Apache Kylin: from 4 through 5.0.4.
Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Vulnerability Analysis
CVE-2026-64610 is exploitable with network access, and does not require authorization privileges or user interaction. This vulnerability is considered to have a low attack complexity. The potential impact of an exploit of this vulnerability is considered to be critical as this vulnerability has a high impact to the confidentiality, integrity and availability of this component.
Weakness Type
What is a Marshaling, Unmarshaling Vulnerability?
The application deserializes untrusted data without sufficiently verifying that the resulting data will be valid.
CVE-2026-64610 has been classified to as a Marshaling, Unmarshaling vulnerability or weakness.
Products Associated with CVE-2026-64610
Want to know whenever a new CVE is published for Apache Kylin? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache Kylin:- Version 4..0.0, <= 5.0.4 is affected.