CVE-2026-111805 is a vulnerability in Apache Traffic Server
Published on October 21, 2026
Apache Traffic Server: HTTP/2 Content-Length truncation lets a client trigger backend worker-pool exhaustion
Apache Traffic Server can be used to exhaust an HTTP/1.1 origin's worker pool via a truncated HTTP/2 Content-Length value.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0.
Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.
Vulnerability Analysis
CVE-2026-111805 can be exploited with network access, and does not require authorization privileges or user interaction. This vulnerability is considered to have a low attack complexity. The potential impact of an exploit of this vulnerability is considered to have no impact on confidentiality and integrity, and a high impact on availability.
Weakness Type
What is a Resource Exhaustion Vulnerability?
The software does not properly control the allocation and maintenance of a limited resource, thereby enabling an actor to influence the amount of resources consumed, eventually leading to the exhaustion of available resources.
CVE-2026-111805 has been classified to as a Resource Exhaustion vulnerability or weakness.
Products Associated with CVE-2026-111805
Want to know whenever a new CVE is published for Apache Traffic Server? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache Traffic Server:- Version 8.0.0, <= 8.1.11 is affected.
- Version 9.0.0, <= 9.2.15 is affected.
- Version 10.0.0, <= 10.1.4 is affected.
- Version 10.2.0 is affected.