CVE-2026-111804 is a vulnerability in Apache Traffic Server
Published on October 21, 2026
Apache Traffic Server: wasm plugin has a use-after-free and forwards unvalidated guest metric IDs
Apache Traffic Server's experimental wasm plugin has a use-after-free in its transaction-close handler and forwards unvalidated guest-supplied metric IDs to the internal stats API.
This issue affects Apache Traffic Server: from 10.0.0 through 10.1.4, 10.2.0.
Users are recommended to upgrade to version 10.1.5 or 10.2.1, which fix the issue.
Vulnerability Analysis
CVE-2026-111804 is exploitable with network access, and does not require authorization privileges or user interaction. This vulnerability is considered to have a low attack complexity. The potential impact of an exploit of this vulnerability is considered to have no impact on confidentiality, with no impact on integrity, and a high impact on availability.
Weakness Type
What is a Dangling pointer Vulnerability?
Referencing memory after it has been freed can cause a program to crash, use unexpected values, or execute code.
CVE-2026-111804 has been classified to as a Dangling pointer vulnerability or weakness.
Products Associated with CVE-2026-111804
Want to know whenever a new CVE is published for Apache Traffic Server? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache Traffic Server:- Version 10.0.0, <= 10.1.4 is affected.
- Version 10.2.0 is affected.