Input in Apache ActiveMQ <6.3.3 & <5.19.12 LDAPPlugin ACL Tamper
CVE-2026-108500 Published on November 4, 2026
Apache ActiveMQ: LDAPAuthorizationMap allows authorization bypass via DN injection
Input validation vulnerability in Apache ActiveMQ configured to use the LDAPAuthorizationMapPlugin allows an authenticated attacker to create or address a destination with a crafted name containing LDAP DN special characters (such as comma, plus, equals, backslash) can manipulate the LDAP search base used for ACL lookups.
This issue affects Apache ActiveMQ: from 6.3.0 before 6.3.3, from 5.19.0 before 5.19.12.
Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
Weakness Type
Improper Input Validation
The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
Products Associated with CVE-2026-108500
Want to know whenever a new CVE is published for Apache ActiveMQ? stack.watch will email you.
Affected Versions
Apache Software Foundation Apache ActiveMQ:- Version 6.3.0 and below 6.3.3 is affected.
- Version 5.19.0 and below 5.19.12 is affected.
- Version 6.4.0 is unaffected.